We're updating the Chrome extension to work with LI's new layout!
Incident Report for Hundo, Inc
Resolved
The extension has been updated.
Posted about 2 years ago. Jan 21, 2017 - 10:44 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 2 years ago. Jan 19, 2017 - 18:05 UTC